
COMMENT FAIRE DE LA MUSIQUE AVEC SON
ORDINATEUR

Introduction.
N’avez-vous jamais rêvé en écoutant un morceau de musique de pouvoir lire en même temps 
la partition, de pouvoir écouter séparément chacun des instruments, de pouvoir chanter votre 
air favori dans la tonalité qui vous convient, de pouvoir jouer le morceau moins vite pour vous
entraîner avec vos instruments favoris, de pouvoir retranscrire une partition dans un traitement
de texte musical et pouvoir ensuite écouter le morceau (car soit vous ne possédez pas 
d’instrument de musique soit vous ne savez pas lire une partition soit les deux).
Alors réjouissez-vous, tout cela est possible grâce au système midi.
Tout ce dont vous aurez besoin, c’est d’un ordinateur muni d’une carte ou d’un chipset son 
(tous les ordinateurs de moins de 10 ans ont ça) et de deux haut-parleurs, de Windows 7 ou 
supérieur et d’un peu de patience pour apprendre à vous servir des logiciels.
Il faut savoir que les cartes son haut de gamme (compter entre 100 et 350€) intègrent 
d’origine un synthétiseur capable de rivaliser avec n’importe quel orgue électronique.
On peut grâce à un clavier midi que l’on branche sur le port midi de la carte son se construire 
un synthétiseur pour moins de 200€ (un clavier maître midi coûte environ 100€).
D’autre part, tous les claviers électroniques (Yamaha, Roland, Casio et autres) dignes de ce 
nom comportent une prise midi et peuvent être raccordés à un ordinateur.

Si vous voulez en savoir plus sur le système midi je vous recommande le site internet suivant :

http://ogloton.free.fr/midi/general_midi.html

Enfin pour conclure cette introduction, sachez que votre voix est 
un excellent instrument de musique et que chanter est très bon 
pour la santé, alors pourquoi ne pas essayer les logiciels de 
KARAOKE,, rien que pour vous, dans votre salon, car chanter 
sous la douche avec un ordinateur présente un risque grave 
d’électrocution !!
Et si le chant est votre passion et que vous êtes bon musicien, aller 
voir cette vidéo sur le Roland Vocoder, ou comment faire une 
chorale tout seul.

http://www.youtube.com/watch?v=RBG8T2f3uBE

Dans cette vidéo, Don Lewis est tout seul.
La voix de son micro est échantillonnée et réinjectée en temps réel dans le vocodeur qui fait la
chorale en fonction des accords qu’il joue sur le clavier
C’est impressionnant, mais bien que cela paraisse facile, ne vous y trompez pas, peu de gens 
arrivent à utiliser avec un tel brio ce genre d’instrument.
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La norme MIDI

M.I.D.I. = Musical Instrument Digital Interface
Cette norme internationale - définie en 1982-83 - est aujourd’hui adoptée 
et utilisée dans tous les domaines de l’informatique musicale et du 
multimédia. Elle est gérée par le consortium MIDI Manufacturer 
Association.
Il s’agit d’un protocole de communication informatique, utilisé et reconnu :
- par tous les ordinateurs (grâce à un boîtier d’interface)
- et par tous les appareils musicaux : synthétiseur, expandeur, BAR, 
machine d’effet, échantillonneur, table de mixage MIDI, jeu de lumières 
MIDI, etc.

Configuration d’un studio MIDI simple.
Pour dialoguer en MIDI avec un ordinateur, il est souvent nécessaire 
d’avoir recours à une interface MIDI. Cette interface est parfois intégrée 
dans l’expandeur ou dans les cartes son sur PC.

Idée de base : un codage du geste
Le MIDI transmet des codes informatiques correspondant aux principaux 
gestes instrumentaux, mais ne transmet pas de son ! La partie gestuelle 
est séparée de la partie génération de son.
La plupart des appareils MIDI sont dotés de 3 prises : IN, OUT et THRU 
(copie directe du IN = prise multiple), sauf les ordinateurs qui ne 
possèdent que IN et OUT (la fonction THRU est réalisée par logiciel).
Les connexions entre appareils se font à l’aide câbles munis de fiches DIN 
5 broches.

Canaux MIDI
16 canaux de transmission permettent de communiquer avec plusieurs 
instruments à la fois sans mélange ou encore de jouer plusieurs sonorités 
simultanément. Chaque message doit comporter la spécification de son 
canal.
Le principe est comparable aux chaînes de TV : 1 antenne, 1 poste de TV, 
mais plusieurs chaînes, chacun son numéro et sa fréquence.

Les codes MIDI
Les codes MIDI comportent une entête (status code), éventuellement 
suivie de une ou plusieurs données (data code). On peut transmettre :
- des notes : hauteur, vélocité, mais pas la durée,
- le choix des sons,
- des paramètres de contrôle du son : volume, pédale sustain, 
panoramique, reverb, filtre, vibrato, appui en fond de touche 
(aftertouch),...
- des signaux de synchronisation entre instruments : boite à rythme, 
séquenceur,...
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- des messages ‘système’ spécifiques : descriptions de sons, données 
techniques, réinitialisation,...
    Entête

   Note OFF
   Note On
   Aftertouch Polyphonique
   Control change
   Program change
   Aftertouch monophonique
   Pitch Bend

   Données
+   hauteur
+   hauteur
+   hauteur
+   n° contrôleur
+   n° de son
+   vélocité
+   valeur

+   vélocité
+   vélocité
+   vélocité
+   valeur

+   valeur

 

    Messages système
   Start / End message exclusif
   Clock   Start   Continue   Stop
   Song pos ptr   Song select
   Active sensing   Tune request   System 
reset 

(description de sons ou messages 
techniques)
(signaux de synchronisation)
(sélection d’un morceau)

 

 Séquenceur MIDI
Constat : un être humain (normalement constitué) ne peut pas manipuler 
simultanément les 16 instruments proposés par les 16 canaux MIDI !
grandes fonctions : enregistrement - relecture des codes MIDI, écriture de 
partition (graphique), traitements MIDI, ...
Un séquenceur est un logiciel (ou parfois un appareil) qui enregistre tous
les événements MIDI qui lui sont envoyés (c’est à dire le codage du geste 
instrumental), puis qui est capable de les relire. L’ergonomie de ces 
appareils est similaire à celle des magnétophones multi-pistes. Les 
séquenceurs sérieux possèdent au moins 24 pistes, sur lesquelles on peut 
construire en détail les divers éléments d'une composition.
Un séquenceur permet la mémorisation de séquences musicales jouées et 
l'accès ultérieur à n'importe quel fragment de ces séquences, par exemple
à une simple note. On peut alors, sans le rejouer, modifier ce fragment 
musical et en multiplier les exécutions, les interprétations, les 
compositions, les transcriptions et autres adaptations instrumentales. La 
mémorisation de séquences permet aussi l'exécution simultanée 
d'enregistrements successifs. Ainsi, un amateur peut-il constituer lui seul 
tout un orchestre après avoir joué séparément des divers instruments et 
les avoir enregistrés un par un.
Les séquenceurs actuels permettent aussi d'enregistrer et de manipuler de
l'audio.
Les séquences MIDI sont enregistrées dans des fichiers sur le disque dur 
(au format LOGIC Audio ou CUBASE ou CAKEWALK ou ...)
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SEQUENCEUR Midi

Logiciel permettant l'enregistrement, la lecture et l'édition des données 
MIDI, lesquelles sont utilisées pour créer ou jouer de la musique 
électronique (à l'aide de synthétiseurs). Note(s): Par l'édition des données 
MIDI, on pourra, par exemple, modifier le timbre, l'intensité, la hauteur des
notes de musique, ou créer des effets sonores spéciaux. 

MIDIFILE
Format de stockage des fichiers de séquences MIDI, défini par la norme 
MIDI.
Le format MIDIFILE est théoriquement compatible avec tous les logiciels et
tous les ordinateurs. Il permet les échanges de séquences entre différents 
logiciels ou différents ordinateurs (Mac, PC, ATARI, NEXT, SGI, Internet, CD-
Rom, jeux vidéos, ...).
Seuls les codes MIDI sont transférés ; toutes les informations graphiques 
ou texte sont perdues.

GM = GENERAL MIDI
Le GM est né d'un besoin d’uniformisation des machines MIDI. Les 
fabriquants de séquences MIDI pré-enregistrées, de logiciels 
pédagogiques, de jeux vidéo, d’applications multimédia voulaient pouvoir 
développer des produits compatibles sur tous les appareils MIDI. C'est une 
pratique mise en place par ROLAND (et suivie par 99% des fabricants), 
mais le GM ne fait pas partie de la définition de la norme MIDI.
Le standard GM définit notamment :
   - la liste des sons d’instruments (128 program change)
   - la liste des sons de percussions sur le canal 10 (drum map)
   - la gestion de quelques effets simples (filtre, reverb, ...)
   - la polyphonie minimale (24 notes jouées simultanément)
   - la multitimbralité minimale (nombre de sons différents joués 
simultanément)
[ plus de détails ]

Quelques définitions
Synthétiseur MIDI : machine autonome possédant un clavier + un 
module de sons
Expandeur MIDI : un simple module de fabrication de son, sans accès 
gestuel ;
    les codes MIDI arrivant par l’entrée MIDI IN pilotent l’expandeur.
Boîte à rythme : expandeur spécialisé uniquement dans les sons de 
percussion
Clavier maître : uniquement un clavier qui génère des codes MIDI, mais il
n’y a pas de module de fabrication de sons.
Echantillonneur : instrument de musique dont les sons proviennent 
d'enregistrements d'instruments réels, de CD...
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La Mao
Musique assistée par ordinateur
Permet de créer, modifier, jouer de la musique en utilisant la norme Midi

Un site d'info qui vaut le detour : 
http://www.01audio-video.com/

Pour ceux qui pensent que Linux ne sait rien faire en MAO
http://www.linuxmao.org/tiki-index.php

Logiciels pour lire du Midi
 Winamp : http://www.Winamp.com
 Windows Media player 
 Van Basco karaoke
 VLC
 et j'en oublie,,,,,

Logiciel pour lire et Editer des fichiers MIDI
http://www.anvilstudio.com

Anvil Studio  ™
Désolé pour ceux qui ne lisent pas l'anglais, il n'existe pas de traduction de leur site internet

This program allows you to: 
 Record, play, compose, and edit standard multi-track MIDI music files, 
 Record, play, and edit audio tracks using standard .WAV files, 
 Compose rhythm tracks with your own sampled percussion sounds, 
 Manage synthesizer Patch Libraries, 
 Practice piano exercises. 

To get started, try the following: 
 To play, record, or compose a song, select Mixer from the View menu. 
 To select which MIDI synthesizers and Audio devices you want to use, select the 

Synthesizers from the View menu. 
 To use your synthesizer in performance mode, select Performer from the View menu. 
 To practice various music exercises, select an item from the Practice menu. 
 If you encounter unfamiliar terms such as Track or Patch Library, you can learn 

what they mean by selecting Terminology from the Help menu. 
 If you encounter any problems, please click the Common Problems item from the 

Help menu. 
 To see if you have the latest version of Anvil Studio, select Upgrade Anvil Studio 

from the Help menu. 
 To shop for Anvil Studio accessories, or to send us email, select Catalog from the 

Help menu. 
 To end the program, select Exit from the File menu.
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LMMS
http://lmms.sourceforge.net/home.php
Je viens d’installer ce soft sur ma machine Linux et je trouve que c’est pas mal du tout même 
avec un vieux PC (Pentium 5)
Il faut passer un peu de temps pour la prise en main, mais cela en vaut la peine, car ce logiciel 
ne se content pas d’être gratuit, il est également multiplateforme et tourne donc sous Windows
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MUSE Score
C’est en français, multiplateforme et gratuit
http://musescore.org/fr

Récupérer des fichiers midi
 www.classicalarchives.com
 Sites des chanteurs
 www.vanbasco.com
 Moteur de recherche
 Dans un moteur de recherche, taper « fichier midi » ou « format midi » ou « Irlande 

midi »

Tout sur l’écriture musicale :
Noteworthy composer    C’est le top pour écrire de la musique , (on peut éventuellement  lire 

des fichiers midi): www.NoteWorthyComposer.com
Bon, c’est encore en anglais et payant

GUITARE PRO
Pour les fanatiques de guitare ce logiciel permet d’écrire des tablatures et de produire de la 
musique au format midi
Voir site Internet :
http://www.guitar-pro.com/fr/index.php?pg=produits
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Texte de chansons
 Sites des chanteurs
 Moteur de recherche
 www.paroles.ne  t

LES KARAOKE
Le top c’est VanBasco, un superbe logiciel de karaoké qui permet non seulement d’avoir la 
musique et les paroles séquencées mais également de pouvoir transposer, changer le tempo, 
visualiser la musique sur les touches d’un piano, se faire une play list, visualiser les 
différentes pistes midi et pouvoir soit les mettre en solo soit les éteindre.
De plus le site de VanBasco permet d’accéder à un grand nombre de fichiers midi de 
chanteurs français ou étrangers (il faut savoir que le gouvernement Raffarin a fait fermer 
pratiquement tous les sites qui diffusaient de la musique au format midi sous prétexte de 
sauvegarder les droits d’auteur ! ! !)

Allez voir ici
http://www.logiciel-karaoke.com/
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WINGROOVE
C’est un logiciel à part qui permet de jouer des fichiers midi et de les enregistrer au format 
wave, sans carte son !!!!(ou comment transformer un fichier de 2Ko en un fichier de 20 
Mo !!)

C’est d’une simplicité absolue !, on aime ou on n’aime pas la banque de sons (c’est 
japonais !)
Adresse : http://wingroove.en.softonic.com/

Exemple concret d’utilisation : on rentre la partoche d’un chant à 4 voix dans le logiciel 
NoteWorthy Composer, ou Musescore on enregistre chaque voix sur une piste, on crée un 
fichier midi.
Nota : Il existe d’autres logiciels permettant de transformer du Midi en Wave  (ou comment 
transformer un fichier de 26ko en un fichier de 3 Mo !!!)
Le plus simple est bien sur d’utiliser un lecteur Midi, mais cela nécessite un ordinateur, alors 
que n’importe quel lecteur de cd peut lire du wave
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BAND IN THE BOX
C’est un orchestre dans votre ordi
On rentre une grille d’accord et le logiciel fait tous le reste (arrangement dans le style choisi 
parmi des milliers de styles disponibles :

Bon il faut mettre la main au porte monnaie mais cela en vaut vraiment la peine

http://www.bandinabox.com/bb.php?os=win&lang=fr

C’est génial !!

Pour ceux qui veulent simplement chanter sur leurs MP3
favoris

On veut chanter ou apprendre à l’oreille une chanson, mais cela va trop vite ou c’est pas dans
la bonne tonalité pour ma voix ou mon instrument de musique,,,pas de panique Monique,

allez voir ici :  http://freewares-tutos.blogspot.fr/2012/01/slow-mp3-un-logiciel-pratique-pour-
les.html

et
http://www.rinki.net/pekka/slowmp3/

Bien sur , AUDACITY fait cela aussi très bien et bien d'autre choses encore, mail il faudrait 
une news pour lui seul !

http://audacity.sourceforge.net/?lang=fr
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